503 error when setting up on my win 8.1 machine

Hey everyone,

I just got started with GetEventStore. Well, I am trying to get started but the force is not strong in this one right now. When I start the 2.0.1 version on my win 8.1 in parallels, I always get a 503 error when trying to do a get or post. When looking at the trace, I did notice a “incorrect version” at some times, but not the last few times I tried. I also checked with Telnet if there was something alive on that port and I was able to connect. I included my log file in attachment.

Any help would be extremely appreciated,

Erik (13 KB)

Have you setup acls etc? We see this commonly with other versions of iis when acls are not setup appropriately

Hey Greg,

Thank for taking the time to help me out. I followed the ACL instructions. My computer does not reside in a domain, so I just used the full computername and my username to add the file. Even then it still tells me that the service is unavailable. I am not getting the “incorrect version” message anymore and I don’t get any error message in fact. It just isn’t available. I’ll add my most recent log file again.


Erik (12.4 KB)

Try removing the ACL and running as admin does it work?

Yeah, it did all of a sudden. I thought I tried running it without ACL, but that was before I disabled UAT. Thanks for the help.