1. Can windows manager be used to run a single event store node as a service or is it used only when setting up a cluster?

  2. I am trying to setup a single node eventstore with windows manager. Most likely I am providing something wrong…I have not been able to get event store working and also I cannot stop the service cleanly. When I try to stop the service, it hangs and writes the following to the event log. Any thoughts?

Failed to stop service. System.NullReferenceException:
Object reference not set to an instance of an object.

EventStore.Manager.Windows.Service.EventStoreManagerService.OnStop() in


  1. Yes

  2. a. What version of Event Store and the Manager is this?
    b. Have you tried running the Manager in interactive mode to ensure that it can start the database node etc just fine?

We are using EventStore 4.0.0.

I ran using interactive mode - The event store runs and I am able to open the UI locally. However, I cannot open the UI from a different machine. Also this error message is logged repeatedly in the console window - "Error while retrieving cluster members through DNS) "

When I install and run as a service, I cannot even access the UI from the local machine and no db files are created.

Manager config

I have been able to get it working in interactive mode. Windows service still does not work and I see no logs as well. Any thoughts?

Which set of logs are you looking at? There’s one set for the database node itself, and another for the manager service.

Both log to the same folder and it is empty when I start the service. I have posted the yaml files I am using. These are the config files I am using


Log: C:\Eventstore\log

Db: C:\Eventstore\es-data


DiscoverViaDns: false


–config C:\Eventstore\database.yaml


EnableWatchdog: true

WatchdogConfig: C:\Eventstore\watchdog.esconfig

Log: C:\Eventstore\log

DiscoverViaDns: false

First one is database.yaml.


has the user the service runs on have read/write access to these directories/files?


Yes, the service is running under my login. I did not see any permission issue when I monitored using process monitor.

I got it working !!! I was running the install command from the current directory, so was not providing the full path of manager.config. I am assuming the service was looking for the config file in the system32 directory.