Projection Corruption

The server’s parent process (terminal) crashed, left a projection in this state:

concurrency violation detected, but the projection is not running. Current state is: CompletingPhase. The reason for the restart is: ‘Checkpoint stream has been written to from the outside’

The projection was not at the time under any load and no writes were being sent to ES.

How to fix?

Screen Shot 2014-12-11 at 11.23.19.png

Another corruption, can’t reset:

“Event number 0 was expected in the stream $ce-principals, but event number 39 was received”

in server logs, GUI shows nothing. I can’t create new projections either, some projections are half-filled.

What happens on reset?

Nothing. Same error same display.

Creating a new projection with same code; nothing, same error for new one too.

Started seeing failures in reading events as a part of the supported API, too.

Example on reading events? A projection checkpoint error should have nothing to do with that

Ok that is good to hear.