Log record at actual pos 5853 has too large length

Hi all, this is the second time I have seen an error about chunk length in a couple of weeks. I am running event store 3.0.5.

This is just from running the event store specifying a DB (originally from the start nothing in the DB directory, this is not a backup), shutting down at night, starting the next day, just let it ran for a couple of days.

I see the error when starting the event store today:

[08244,10,07:01:23.002] Error during processing ReadAllEventsForward request.

Log record at actual pos 5853 has too large length: 540680808 bytes, while limit is 16777216 bytes. In chunk #0-0 (chunk


The files compressed with WinRAR-5 are here: [https://dl.dropboxusercontent.com/u/50207381/db-test-logs.rar](https://dl.dropboxusercontent.com/u/50207381/db-test-logs.rar)

in case there is a way to diagnose this would be interested to hear it… there is no sensitive info, just a test customer aggregate with a couple of events has been written every second.

The SSD drive itself seems fine, and will try a different one, just wondering if anyone has seen similar issues.




Are you running a subscribe to all subscription or reading this
yourself? The most common cause for this we see is passing a bad
checkpoint/read location to the subscription/read operation

Hi Greg, this happens on starting the event store from the console without running any user code, so no subscriptions or external reads are happening.

So I see this is only about 5k into the log. Can you tell me more
about your setup? I would normally expect such a common issue to show
up in our tests. It seems you are in windows, do you have windows disk
caching enabled?

Its Windows 8.1 Pro, I have a C drive (SSD), D drive 1TB SATA, and E (SSD kingston)… I will try again on a different drive in the event it is in the kingston (although all diagnostics are showing it as 100% OK).

Disk caching is default as per windows policy, certainly haven’t been fiddling with anything that could cause data loss.

Right click on your drive that you put your data on. There is a
setting in there "write caching"

Hmmm ok, so presume this applies: https://geteventstore.com/blog/20131218/disabling-disk-caching-in-ubuntu/

and should also be disabled (since by default it is on in Windows) - unless i missed something would be great to mention in getting started :slight_smile: apologies if it is, and sorry if seems an obvious question as I have learnt a lot today.

This is highly dependent on the hardware configuration you’re running on - for some disks it’s OK, for some not.