How to turn on MFA for the system owner (me)

I was able to Require MFA for invited members in the Organization > Access Control area, but how do I turn it on for my own account. This policy doesn’t seem to apply to me, since I’m the account owner. I’ve looked all over for other controls for MFA but can’t find them. Thoughts?

Good point. From what I see now, I agree, the MFA policy only applies to “invited members”. Will bring it up with the Cloud team.

While you’re doing that, it also appears as if the “invited members” policy isn’t being applied. I checked with my team and they have not been forced to turn it on and have no way to turn it on themselves.

Thanks, will pass it over.

Basically, we haven’t done MFA yet, so the checkbox has zero effect. Until we actually do it, we’ll remove the checkbox in the next release.

Got it. Thank you for the update.