External connections to an eventstore cluster when the IP is routed and not actually assigned to the servers


I’m trying to set up an event store cluster for testing in Azure, and have 5 identical VMs each with a reserved public IP address. These IP addresses are not directly added to the machines (they are merely translated to the local equivalents).

As they aren’t set on the machines I don’t appear able to set the correct IPs as “external IPs” and when I use gossip seeds to attempt to connect to the cluster over an external IP address it then appears to try to connect to the LAN address (10.0.0.*).

Is there a way to get the server to accept that it’s externally visable IP address may not be directly assigned to the computer on which is runs and to get the gossip to return the correct, externally facing, IP address to the client?

Thanks for any help :slight_smile:


Peter Stephenson

Hi Peter,

The command line option –ext-ip-advertise-as seems to be what you’re looking for here.

This option sets the address that the node reports as its external address in the gossip, but doesn’t change the ip address the node is actually using.

You can also change the advertised ports using the options –ext-tcp-port-advertise-as and –ext-http-port-advertise-as.

Thanks :slight_smile:

Confirming that setting that option has resolved the issue!