Examining eventstore service's standard output/errors on Ubuntu

Forgive me if this ends up being a Linux newbie question, but I’m wondering how to examine the Event Store service’s output messages on Ubuntu 14.04, having installed Event Store via the Debian package method.

We have a VM where the ES service is starting but then immediately stopping, and the log folder /var/log/eventstore is completely empty. I tried to run /usr/bin/eventstored directly but it just gave me a readout of (the many) command line options.

If I could just see what initial error message got spit out (but not logged) hopefully I’d have insight into why Event Store won’t start on this particular VM…

This is likely an invalid option in the configuration file or the address being in use.
Can you provide us with the output of running /usr/bin/eventstored?

I don’t think anything goes to standard output (I’ve tried piping it to “more” and to a file - it’s empty); no matter what we do, it just dumps the man page for the command line options. And since I can’t page that with “more” I can’t tell if there’s anything at the top of the readout I need to see.

In case it helps, here’s our /etc/eventstore/eventstore.conf



IntHttpPrefixes: http://*:2112/

ExtHttpPrefixes: http://*:2113/

AddInterfacePrefixes: false

RunProjections: All


Please can you provide us with the result of running /usr/bin/eventstored, please include everything, from the point where the command was issued. I understand that it will include the numerous command line options, but I want to see everything from the point the command was issued up to where it stopped.

As I feared, this was a Linux newbie issue. I realized that the man page output I was seeing was the standard error output, so as soon as I figured out how to send that to a separate file:

sudo /usr/bin/eventstored > stdout.txt 2> stderr.txt


…as soon as I did that I could see the top of the error message - the important bit - and then it was clear we had a faulty config file. My bad: I did not post the correct config file in my reply above.

The actual config file had a duplicate key entry which, once removed, cause a normal start of Event Store.

Sorry about that, all…