event store client v4 for .net 4.5.2

I have a project that targets .net 4.5.2. When I install the v4 client I get this in my packages.config:

however when I then try and build the project I get this error:

warning MSB3274: The primary reference “EventStore.ClientAPI, Version=, Culture=neutral, processorArchitecture=MSIL” could not be resolved because it was built against the “.NETFramework,Version=v4.6” framework. This is a higher version than the currently targeted framework “.NETFramework,Version=v4.5.2”.

Am I doing something wrong? Or am I forced to update everything to .net 4.6 in order to use the v4 api?



In this case .NET only supports backward, not forward compatibility, so you’ll need to upgrade your project settings to at least 4.6.

Version 5.0.0 now looks to target .NET 4.5


but I would consider reading through all the bugfixes in their release notes to see if you really feel the product is production ready.