ES database on network share = Error: CommitTimeout + status code 500?

Hey there,

we are using the Http Api to talk to ES. Yesterday we tried to write a couple of thousand events to our DEV-environment ES but after the first few thousand we reproducibly get a 500 server error. I took a look at our logs and found entries containing the phrase “Error: CommitTimeout” at the time of the errors.

Now there could be different reasons for this error:

  • we are using a january version of ES, if it was an error in ES it could be already fixed in the current RC2

  • I’m not sure, but from the logs it looks like the error has something to do with projections which are still in beta

BUT: everything worked fine on our local DEV machines so I pretty sure the problem is related to how our DEV server is configured: our ES database files are located on a network share, which feels wrong. I would like to change that, but I’m not sure this will be possible, due to organizational guidelines.

Did somebody have a similar error or do you have any ideas what could have caused it?

Thanks in advance!



Don’t do this unless it’s a SAN with the correct drivers installed (likely iscsi)

The file handles tend to disappear underneath you with a network share, we saw this before.

Thanks James, I will investigate our options.



Yes, I already tried this and it didn’t work well either.

I’d recommand storing locally with a good backup plan…