Embedded inmemory and logging

Hi. I have a very strange case where an xunit test with embedded, in memory, EventStore passes in Resharpers test runner, but not with dotnet test or Visual Studio. (EventAppeared is never called on a catchupsubscription).

Have been trying to get logs from the client connection to see what’s different, but nothing appears. Tried with ConsoleLogger, FileLogger and Custom wrapping Xunits ITestOutputHelper. Using version 4.1.1, tried with 5.0.1, same problem. Using the same custom logger for other output, works as expected.

I’m pretty sure this used to work? Client logging in production works as expected.


If you set a break point does it get hit?

There are no major changes I know of with client logging… Many people use the client logging. I am unsure why the situation might be different.

Nope, nothing in custom logger gets hit.

Tried running the same code in cli, only output I get is: Exiting with exit code: 0.
Exit reason: Shutdown and exit from process was requested.

Connecting to a running ‘proper’ instance logs as expected, so it looks like something with embedded. I’ll have a look at the es source time permitting.


I figured I’d solve the actual problem against a running instance, but looks like I can’t recreate it, test passes in all runners as long as I don’t use embedded.