disable projections error


When trying to disable projections I’m keep getting NOT AUTHORIZED exceptions in management UI (clustered node 3.0RC on windows server 2012).

In ES log, I can only see:

[PID:04288:014 2014.03.20 14:22:48.705 INFO ProjectionManager ] Disabling ‘$by_category’ projection

but nothing else is happening.

The same thing happens with projection edit - it requires to make 10-20 button clicks until requests are handled?

Is this a natural lengthy operation or it is some kind of bug?

Is the node you are connecting to the master? (you can go to /gossip to see information)

What does the node you are connected to print when you disable the projection?

Yes. This was the problem (just figured that out.)
Anyway, thanks for the prompt reply!

Also it would be could to put some simple info box or sth. it would save time for other people :slight_smile:



It should work from any node. We jsut saw an issue with http forwarding and figured it was likely the same. Did you get any error messages on the nodes about http?

No, error log seemed to be clean at that point.