Cannot use projections or query

I am new to using EventStore; however, I cannot use the projections or query features. When I attempt to run a query, I get:

$init: function() {
return { count: 0 }
“vix”: function(state, event) {
state.count += 1


oops, that is what I ran, these are the logs:
[27445,06,01:24:23.204] Replying 404 for /js/ace/worker-javascript.js ==> /js/ace/worker-javascript.js
[27445,15,01:24:32.988] Replying 404 for /js/ace/worker-javascript.js ==> /js/ace/worker-javascript.js
./clusternode: symbol lookup error: ./ undefined symbol: _ZN2v87Isolate3NewEv


are you running with --run-projections=all and do you have
LD_LIBRARY_PATH set to include where libjs1 is?

I am not running with no-projections; however, I do no have LD_LIBRARY_PATH set at all; what should it be pointing to?

I am not running with no-projections;

you need to run with --run-projections=all

LD_LIBRARY_PATH needs to include where libjs1 is. The scripts included
in binary release set this if you use them

Okay, I ran with and --run-projections. I tried with setting LD_LIBRARY_PATH also. This fixed the shared object crash; however, the create button for projections is still grayed out and I still get:

[27784,06,01:43:07.679] Replying 404 for /js/ace/worker-javascript.js ==> /js/ace/worker-javascript.js

Also, thank you so much for the quick responses.


This is what I ran: LD_LIBRARY_PATH=. ./ --db ./db --log ./logs --run-projections=all
Still ran into that issue

It should work fin (though I believe we already set LD_LIBRARY_PATH in

What version is this?

Just verified downloading binaries 3.0.3 from website.
--run-projections=all and have "new projection" button available

[joejev@Sheila EventStore-OSS-Linux-v3.0.3]$ ./ --version
EventStore version (master/a1382252dd1ed0554ddb04015cdb2cbc1b0a65c1, Fri, 13 Mar 2015 13:56:05 -0400)

I am using the downloaded binaries, when running the server with:
./ --db ./db --log ./logs --run-projections=all

I cannot click create:

Maybe I am missing something

Try putting a name in

I am dumb. Maybe technology is not the field for me.

Thank you for your time.

@pieter maybe we should put up a message on this to make it clearer?

Well that’s interesting.

I read a blog post on web ux last week that advised against disabling submit buttons by default. Instead, clicking the button should report what needs to be done to make the form valid.

I always disable the button until the form is ready to submit, so I blew that advice off as hipster nonsense.

Now I’ll have to reconsider. :smiley:

You can do both by setting the title attribute on the button :slight_smile:

Not for touch. :smiley:

This bit me too. I think it’s because the fields look like a normal table, and the yellow background in the “Name” input just didn’t draw my eye too it. I focused on the code window. Took reading this thread to realize what was wrong… and even then for a minute, I thought Greg’s comment of adding a “name” was referring to something in the command line args!