Cannot start event store

Downlaoded the latest event store and tried to run the following command in zshell

./ --db ./ESData

./ line 2: ./clusternode: cannot execute binary file

I installed mono on mac. Am i missing something?

Thanks in advance for your help,


You don’t need to install Mono if you’re using the packages like that. The error message suggests either you’re running i686 instead of x86_64, or that you’re running the Linux binaries on OS X. What’s the name of the file you downloaded?

Thanks for your response. I just downloaded the wrong distribution (linux distro on mac). Are there any good incremental learning tools that you can point to get started ?



For http the "getting started with http guide" in docs is not a book
but a reasonable start

I am having the same problem. I am using the latest version of Ubuntu, and downloaded eventstore oss mono Ubuntu 3.3.0

I am running Ubuntu inside of virtual box on widows 10.

I get this same error:

./ --db ./ESData

./ line 2: ./clusternode: cannot execute binary file

There are a number of issues here. Can you confirm whether you installed the package or downloaded a .tar.gz?

Typically “cannot execute binary file” means that the binary you are trying to run is built for a different architecture than your system. Are you running a 32 bit version of Linux?

Also the latest version of Ubuntu I believe has switched to systemd, meaning the init scripts in the packages are not compatible. We currently only produce packages for the most recent LTS version of Ubuntu.